Symptom

#1 On the new version of Chrome/Edge (version 98), if you open a PowerServer (2020 or earlier) Web application using the HTTPS connection, you may get the error: Appeon Web application has quit successfully. Please refresh the browser. 

it displays a page as shown in the screenshot below:

#2 On the new version of Chrome/Edge, if you open a PowerServer (2020 or earlier) Web application using the HTTPS connection, leave it in idle for a few minutes and then go back to the application, you may find it displays a blank page as shown in the screenshot below:


Cause

Caused by some internal changes of Chrome/Edge. It is still under analysis.
 

Resolution #1

Please upgrade to Chrome Version 98.0.4758.102 or Edge 99.0.1150.30 to solve this issue.


Resolution #2

Please follow the steps below to use the attached multi_browser_indexs.htm which is renamed from multi_browser_index.htm to solve the issue. This only affects the communication between the local browser and AppeonMultiBrowserLauncher.exe and it does not affect the HTTPS communication between the client end and PowerServer.

1. On the PowerServer machine

    For .Net server:

a. Extract the file Template.zip from C:\inetpub\wwwroot\appeon\developTempFile.

b. Use the attached multi_browser_indexs.htm to replace the one in the extracted Template folder.

c. Compress the Template folder in Step #2 and replace the original file C:\inetpub\wwwroot\appeon\developTempFile\Template.zip.

    For Java server:

You can use a tool like 7-Zip to replace the file in ear.

The multi_browser_indexs.htm is located at appeonserver.ear\appeon.war\developTempFile\Template.zip\Template\release(debug). You can refer to the link below for more details:

https://stackoverflow.com/questions/15199535/update-a-single-file-in-the-ear-file-in-a-better-way

For example, in JBoss, please follow the steps below to update the file in appeonserver.ear.

a. Backup %JBOSS%\standalone\deployments\appeonserver.ear.

b. Open appeonserver.ear in 7-Zip. 

c. Go to appeonserver.ear\appeon.war\developTempFile\Template.zip\Template\release. 

d. Drag the attached new multi_browser_indexs.htm to 7-Zip to replace the original one.

e. Save it.

f. Go to appeonserver.ear\appeon.war\developTempFile\Template.zip\Template\debug. 

g. Drag the attached new multi_browser_indexs.htm to 7-Zip to replace the existing one.

h. Save it.

2. On the Toolkit machine.

a. Delete folders/files under the template & cache folders from the Toolkit path, for example:

    C:\Program Files (x86)\Appeon\PowerServer 2019\Toolkit\Template

    C:\Program Files (x86)\Appeon\PowerServer 2019\Toolkit\TemplateCache

b. Deploy the application again. Please check the multi_browser_indexs.htm in %Your Application% folder on the web server and make sure it’s updated.

3. On the Client machine

Run the application and make sure it loads the updated multi_browser_indexs.htm correctly. It’s recommended that you clear Chrome/Edge cache before you run the application.

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