Symptom
1. When using an online license, try logging into PowerBuilder/InfoMaker with your username and password but get the error message “Cannot find a valid license.” after clicking the Log In button.
2. When using an offline license, try submitting the Client Request String to the Appeon Website but get the error message “Cannot find a valid license.” after clicking the Log In button.
Environment
PowerBuilder
InfoMaker
Cause
1. No corresponding online/offline license is assigned to this account.
After a user successfully placed an order, this user becomes the license owner/administrator of all licenses in this order, and this user still needs to further assign the license to a user account before they can log into PowerBuilder/InfoMaker.
If you try to use an online license to log into PowerBuilder/InfoMaker when you have a license assigned as offline to you, you'll get the "Cannot find a valid license" error, and vice versa.
2. The license assigned to this account is not currently valid.
The PowerBuilder/InfoMaker license is only valid within its Valid Period. For example, if today is 2022-01-01 but the license's valid period is 2022-02-01 to 2023-02-01, then it will not be valid to use until 2022-02-01.
Resolution
1. If you don’t have a currently valid online/offline license, please ask your license administrator to assign one to you referring to Assigning users.
2. If you have an online(offline) license, but you need an offline(online) license, please:
(1) Unassign the current license from the user first.
(2) Assign the license as an online license or assign the license as an offline license by referring to the instructions in Assigning users.
(3) To activate an online license, please follow the instructions in Loggin in with an online license.
(4) To activate an offline license, please follow the instructions in Activate with an offline license.